After installing Java 7.0 (1.7) and reapplying PTF's on a working Showcase 9 server the server failed to start. Per KBA-33283-S4H9W2, the showcasecorp.scserver.jvm.path parameter in the showcase.cfg was used to force the server to use Java 7, and the server started successfully. Batch queries began to fail while iInteractive queries ran fine. The BATCHQUERY job logs indicate that Java 6 (1.6) is being used. No logs or artifacts indicate a problem or record an error.

This is apparently a Java-related issue, and it is known that:

  1. The problems started after Java Licensed Programs were installed and Java PTF's applied.
  2. Switching the Showcase server to use Java 7 (1.7) resolved the problem with the server starting.
  3. Batch queries continue to use Java 6 (1.6), and this appears to be the reason why batch queries are also failing.
  4. Interactive queries run fine.
  5. There is no evidence to indicate the type of problem encountered by Java (No dumps, and no other Java-related logs. The BATCHQUERY and server job log don't have any errors related to this)

The IBMi system where this occurred was using V7R2, but it is thought that this could affect OS versions V7R1 and V7R3, as well.


It's possible to force batch queries to start a specific version of Java. Batch queries use the same module to submit queries via the IBM DB2 JDBC Driver that Warehouse Builder does. Therefore, this setting affects both Warehouse Builder and batch queries simultaneously.

  1. Edit the showcase.cfg file, which is located in the IFS directory //SCSERVER/proddata/config (where scserver is the name of their Showcase library).
  2. Near the top, under Server Properties, insert a couple of blank lines and paste this on one of those lines:


  3. Save the changes and restart the Showcase server. The showcase.cfg can be edited while the server is running, but the server will need to be restarted before the changes will take effect.
Still have questions? We can help. Submit a case to technical support

Last Modified On:
You don't have the appropriate permissions.
No, open a new Support Case