Intermapper and Intermapper Flows do not need to run on the same server. In fact, this may be necessary when Intermapper Flows is handling a lot of flow data. You can leave the Intermapper server running on its current hardware and use a higher performance system for the NetFlow analysis.

The two servers communicate through a TCP connection. By default, they connect through localhost, but this can be changed by modifying two configuration files. You need to do the following:

  • Install Intermapper Flows on the Intermapper server - You can use a very small database size - this is only to get the proper files installed on that server. You do not need a serial number for it, as it will not be "in production." You can even stop the service/daemon by following the instructions on the ReadMe page.
  • Configure Intermapper to connect to the Flows server - On the Intermapper server, edit Intermapper Settings/Extensions/flows.xml to have an "address=" line, as shown:, where is the address of the IM Flows server:
      name='Intermapper Flows'
      version='build????' >
         class='com.helpsystems.intermapper.flows.remote.NSPluginIMFlows' />
  • Install Intermapper_Flows on the other server - Configure Intermapper Flows for a large database size.
  • On the other server, edit the /Intermapper/flows.conf file - On the Intermapper Flows server, add this line near the bottom (but above the "# EOF" line) of the flows.conf file:
    localhostonly no


# Automatically generated configuration file

# WARNING: this file might get overwritten by the application!
# Manual changes are accepted based on your license agreement.
# If you want to save a copy (including your comments), please
# make a backup copy of your modified configuration file

prefdatabasesize medium
databasepath C:\ProgramData\Intermapper\Intermapper Settings\Flows\SESSIONDB
storageinterval 3
memcachesize 2097152
conntracksize 104857
netflowport 2055
dodataguessing no
assumedbytesperpacket 1000
sflowport 6343
hostcolors byvalue
portcolors contrast
logfile C:\ProgramData\Intermapper\Intermapper Settings\Intermapper Logs\flows.log
querythreads 2
nddimf_enabled 2
debuglevel HIGH
license IMFlows_EVAL-W71R-6M71-3FGZ-YWG8-827N-W80W
user Fortra License Key
localhostonly no


Now that the configurations have been made, make sure the Intermapper server has the flows service disabled, and the Intermapper service running. On the flows server, have the flows service running and the intermapper service disabled. Now on the Intermapper server you can open the flows window and use it as you normally would.

Still have questions? We can help. Submit a case to technical support

Last Modified On:
You don't have the appropriate permissions.
No, open a new Support Case