This error message can occur when Windows is booted or the Task Administrator is opened and the service is either not able to respond or cannot be reached via TCP/IP.


There are two things that are important to understand when diagnosing the cause of this message:

  1. Various portions of Automate use TCP/IP to communicate with each other, even when communicating on the local machine.
  2. is a loopback network connection. For example, if you telnet, ftp, etc... to127.0.0.1, you are immediately connected to your own machine.

What does all this mean? A component was unable to send a message via TCP/IP to another component of Automate.

Automate 5 uses TCP Port 7477 by default. Automate 6 uses 7677. It would first be a good idea to check the Task Administrator, System, Options menu under the System tab to verify that you using the correct port.

Verify that your firewall is not interfering with Automate’s ability to send TCP/IP messages on the specified port.

Note: You may have a firewall and not even know it! Windows XP Service Pack 2 and Windows 2003 Server both include a firewall that can be accessed through the control panel.

With Windows XP you can simply double-click on “Windows Firewall” in the control panel; with Windows 2003 Server you need to double-click on “Network Connections”, right click on the applicable connection, go to the “Advanced” tab under “Properties”, and click on “Settings” in the firewall section.

Although Automate works fine with the default Windows Firewall settings, modifications could be unnecessarily restricting local communications via TCP/IP.

Check that your Antivirus software or other system security software is not interfering with Automate’s ability to send TCP/IP messages on the specified port. Norton Antivirus and McAfee are known to do this.

If you have gotten this far and you are still having problems, it is time to make sure that the Automate Task Service is running. Go into Windows’ Control Panel, Administrative Tools, Services.

  1. Do you see Automate 5 or 6 listed in there?
    If not, skip to step 3
  2. Is it running under LocalSystem (“Log On As” column)?
    If not: Right click, go to properties, Logon tab, set it to log on as LocalSystem. Make sure “Allow service to interact with desktop” is UNCHECKED.
  3. Is its status “Started?” Are you able to stop and start it? If not...
        1. Right click on the Automate icon in the system tray (next to the clock) and Exit.
        2. Go to Start, Run, type “regedit”, and press enter.
        3. Find and delete the two following keys
            1. HKEY_LOCAL_MACHINE\Software\Network Automation
            2. HKEY_CURRENT_USER\Software\Network Automation
  4. Open Automate and see if the problem persists. If so repeat the following steps, but uninstall / reinstall Automate completely after step 3

Applies To: Automate 5, Automate 6 

Still have questions? We can help. Submit a case to technical support

Last Modified On:
You don't have the appropriate permissions.
No, open a new Support Case