Q. I am using a MultiTech Multimodem MTCBA-U and I am unable to send a successful test SMS message. I am using the latest driver from MultiTech.

A. The speed for the factory setting on this modem is set to 115200. Running the MultiTech driver at 115200 is inconsistent and often fails. Once it has failed, it is hard to recover to a usable state. A slower baudrate avoided these problems. Because SMS has such a low volume of data, try using a baud rate of 9600 in the notifier settings and set the modem to either 9600 or autobaud (0):

For autobaud: AT+IPR=0
For 9600: AT+IPR=9600
To save config: AT&W