Q: We are a very small business running Intermapper. We have two Cisco routers on our network, a 1921 and a 891. I configured these routers to export netflow data to my server running Intermapper. It worked fine.

A few months back I made a few changes to the routers and Flows stopped working. We weren't really using it much, so we didn't try to fix it at the time.

We have now identified a use for it and would like to get it back up. I have configured it using the exact same youtube video I used before, but it is still not working. The only thing that has changed is the destination IP which I updated correctly.

Here is what I have:
ip flow-export source GigabitEthernet0/1/0
ip flow-export version 5
ip flow-export destination 2055

interface GigabitEthernet0/1/0
ip address
ip access-group 102 in
ip flow ingress
ip flow egress
ip nat inside
ip inspect test out
ip virtual-reassembly in
negotiation auto
no cdp enable

I have tried quite a few things other than what you see above-

I have tried it with and without NAT statements specifying the destination server and ports.

I have tried it with and without ACL permits on the servers and ports.

I have tried it with and without the inspect statements.

The router changes I made were in the ACLs and Inspect statements which is why I tried all that.

A:  The major difference I see between your configuration for the interface and the example we have at flows is that you've used "ip flow ingress" and "ip flow egress" instead of "ip route-cache flow". I am led to believe that the former configures flows on subinterfaces, while "ip route-cache flow" configures flows on the interface itself.

I would remove the "ip flow ingress/egress", add the "ip route-cache flow", and then check with the following commands:

show ip flow export
show ip cache flow

This shows what flow information is being exported.