Posted Fri, 30 Nov 2018 04:59:55 GMT by

We are experiencing an issue when importing AML files.

Initial import of tasks (single or multiples) works successfully and script functions as it should. If server is locked, logged off, or switched account the next import fails until we reboot the server. After server restart, tasks will successfully import.


We receive the error message below, which seems to be the same issues others have been experiencing.

 "The AML is invalid or incorrect for 'nameoftask' for the requested operation."


Any resolutions or workarounds for this issue?



Posted Sat, 19 Jan 2019 09:08:24 GMT by

Yep 2 months ago and this is still an issue.  The first function after install and configure and does not work.

Posted Thu, 18 Apr 2019 04:30:10 GMT by

I've used Automate since version 5.x and these import issues seemed to start when version 9 was introduced.  If I could go back and access the old Automate forums, I'd find my old posts that state the same issues we're all experiencing now.  

One thing I just did, to verify what I figured must be part of the problem, was replicate one of my more simple tasks from v10.5.0.56 to v.  Then I compared the AML files and it's pretty clear the structure of those files is very different.  And I imagine that has to be part of the issue when importing.

Do you see the same differences?

Posted Sat, 20 Apr 2019 04:37:18 GMT by

Hi Craig,

Can you share a task that is not importing?

Posted Wed, 24 Apr 2019 02:01:26 GMT by


Take your pick.  None of the v10 tasks import correctly.

I'm attaching an existing task that I attempted to import to the install.

"The AML is invalid or incorrect for 'Cleanup ImportExport' for the requested operation."

Now if I manually recreate the task in v11 - it's pretty clear that the Import/Migration logic isn't working correctly to convert a v10 task to the required format.

This has been a persistent problem every time moving from one major version upgrade to the next.  And sending in a catalog of tasks to Support to get properly converted is not the answer.

Lucky for me, I "only" have 41 tasks to manually recreate in the event we want to move up to the next version.  I feel for those who have stated they have hundreds.  They should just be able to Backup their version 10 and Restore into version 11, or Import their v10 task files into v11, without issue.


Posted Thu, 25 Apr 2019 00:45:55 GMT by

Hi Craig,

I don't see many import issues these days.  I was actually able to import your task just fine into v11.  Perhaps there's an issue with the setup there.  If you'd like, I can connect with you and troubleshoot it on your system.  Please email [email protected] with your availability.

Posted Thu, 25 Apr 2019 05:42:51 GMT by


Posted Fri, 26 Apr 2019 01:45:31 GMT by

Just within this thread are 3 different customers stating they're seeing import errors.  The topics in this forum topic are primarily import errors.  There's even thread that seems to point to an import bug related to custom descriptions.

I even created a simple 1 step Write to File task in v10 right now, ran it successfully, exported to the server's Desktop, and tried to import that .aml into the v11 install on the same machine.  Both x86, different install directories, different Task directories.  No custom descriptions. Same error.

I'm nearly done manually rebuilding our tasks, and I'm certain there are no setup issues - as I've been running 4 environments for years (DEV, TEST, STAGE, PROD) and don't have any issues day to day.  It's just the version to version import process that continues to plague many of us, and that doesn't seem to be addressed.


You must be signed in to post in this forum.