Posted Thu, 03 Sep 2020 18:42:07 GMT by

 Hello - has anyone seen and solved this error when opening/creating excel actions?

Unable to cast COM object of type 'Microsoft.Office.Interop.Excel.ApplicationClass' to interface type 'Microsoft.Office.Interop.Excel._Application'. This operation failed because the QueryInterface call on the COM component for the interface with IID '{000208D5-0000-0000-C000-000000000046}' failed due to the following error: Element not found. (Exception from HRESULT: 0x8002802B (TYPE_E_ELEMENTNOTFOUND)).


I have tried all the popular internet suggested solutions related to clearing the registry editor for Computer\HKEY_CLASSES_ROOT\TypeLib\{00020813-0000-0000-C000-000000000046}\1.9\0\Win64 but no luck. 


Posted Sat, 05 Sep 2020 05:22:44 GMT by

Hello Laureen,

Is this happening with just one excel file or all?

When did this issue start occurring? After an update of some kind?

Posted Mon, 07 Sep 2020 15:14:34 GMT by

Hello Alex. It started happening 'out of the blue'. And yes with all excel files when using the excel actions. But not with openspreadsheet actions. Also not with a simple run action.

Posted Mon, 07 Sep 2020 23:00:33 GMT by

Hello Laureen,

I think your Excel is not licensed. Try licensing Microsoft Office before you use Excel Actions.

Alternatively, you can use OpenDocument Spreadsheet to automate .xlsx, .xls or .xlsm files.




Posted Tue, 08 Sep 2020 18:31:31 GMT by

Hello Rizwan. Definitely not a license issue. License is current and activated. Yes I have been using OpenDocument Spreadsheet in the interim. Still would love to hear from anyone else who has had this problem and solved it. Thanks! And once I have the fix I will gladly post here as well.

Posted Wed, 09 Sep 2020 02:57:05 GMT by

If this is not a code related error than please remove below given key from registry.


Start--> Run --> regedit --> HKEY_CLASSES_ROOT-->TypeLib-->{00020813-0000-0000-C000-000000000046} --> 1.8/1.7 (Delete this)

Solution: This issue can be resolved by deleting an invalid registry key left over from the higher version of Office. Follow the above steps.

Cause: This issue is caused by a left over registry key if you have downgraded your version of Microsoft Office from either Office 2010 to Office 2007, or Office 2013 to Office 2010 or 2007.


Let me know if this solution is not helped to you

Posted Wed, 09 Sep 2020 15:09:32 GMT by

Hello Rizwan. Thanks for this. Very kind of you to keep trying to help. The reg ed was the first thing I checked before starting this post last week. And no I have no invalid keys in the reg (only have 1.9). 

Posted Wed, 09 Sep 2020 19:01:03 GMT by

Hello Rizwan and Alex. Thanks for all your assistance. The problem has been solved through a number of actions including re-installation of the MS suite none of which worked and finally after doing a Microsoft 365 Apps & Features Modify Quick Fix the error disappeared. 

Posted Thu, 02 Dec 2021 16:12:46 GMT by DEEPAK PANDEY
Could you please provide more details on what you did for resolving this issue after making changes to "Microsoft 365 Apps & Features Modify Quick Fix the error disappeared.".

Can you please add what steps you made in order to resolve the issue.

You must be signed in to post in this forum.