Posted Wed, 25 Sep 2019 01:42:50 GMT by

 Hi guys,

We are implementing a task with Automate Plus to get values from Terminal and, for some cases, we have more than one page and we need to send “F8” command key, to Terminal to go to the next page. 

The problem is the encoding sent for Terminal is ^[[19~ instead of {F8} command, and we were unable to see the next page.

The Terminal that we are using have "VT400" encoding, which is not supported on your emulation types. Anyway, we already tried every emulation types, but the result is always the same.

We also tried to send some other commands like {ESC}8 or {NUMPAD8}.

Anyone had this problem before and have any idea about how to solve it?

Thank you.

Best regards.



Posted Wed, 25 Sep 2019 03:54:29 GMT by

Hello Joao,

I have seen cases where clients have terminal session that will respond to regular "send keystrokes" action. Especially since this action has the ability to send function keys (see attached).

Is it possible to try the Input-Send Keystrokes action?


Posted Wed, 25 Sep 2019 16:54:29 GMT by

Hi Alex,

Thank you for your help! 

That was our first try and the result was the same :(


Posted Fri, 27 Sep 2019 00:53:40 GMT by

Hello Joao,

We apologize for the issue you are encountering. The issue may be the type of emulation, VT400.

We will need to send a feature request for this type of emulation to be supported in the future releases of the software.

We will update this thread with the feature request number ASAP.

You must be signed in to post in this forum.