Posted Mon, 24 Sep 2018 20:04:16 GMT by

Automate - Windows Server 2008R2

When searching in the Repository for tasks, when starting at the task level, searches do not seem to always include the sub-folders. I will often have to search in the individual user folders to find a particular task. Is this a known issue or is there a setting/work around to correct this?



EJ Stanley


Posted Tue, 25 Sep 2018 22:54:07 GMT by

Hi EJ,

Unfortunately we were not able to replicate this behavior in our testing. Are you just entering the search string in the box or also pressing enter or clicking the search button. If you are just entering the text in the box, this acts as a filter for the current folder.

Posted Tue, 25 Sep 2018 23:23:55 GMT by

I'm just entering the search string in the box. However, I see no difference if I also press enter or click on the search button. I'll attach two images. One displaying what I see when i enter the search string (press enter or click search) at the Tasks level and a 2nd image showing the same attempt from the user folder level.

Posted Wed, 26 Sep 2018 03:21:31 GMT by

 Hi EJ,


Are you logged into the Administrator account or a user account?  If this is with a user account, please try while logged in as the Automate Enterprise Administrator.

Posted Wed, 26 Sep 2018 20:53:54 GMT by

 Hi Team,

I'm not seeing a difference when using a regular user account vs the administrator account.

Posted Wed, 26 Sep 2018 22:51:15 GMT by

Hello EJ,

We would like to be absolutely sure of the process you are undertaking to test this. Please reference the attached gif. As you can see, I have a task called "test" under the user "1" folder (as well as a workflow called test buried in subfolders as well). In the gif, when I type in the word "test", nothing appears at first. Not until I press the magnifying glass icon, do I get results of not only the task itself but the workflow as well.

If this is the process you are doing, please try the following. First, close all instances of the SMC. Next navigate to the following location:

C:\Users\USER NAME HERE\AppData\Roaming\AutoMate\Automate Enterprise 11

...and delete the "SMC Preferences.xml" file, and the "SMC Reporting.xml" file.

Reopen your SMC and try your test once more.

Please let us know your results.

Posted Tue, 02 Oct 2018 11:43:11 GMT by

Wouldn't mind have this question answered. Same issue here. If you are using the UI, the search doesn't allow searching across all folders or subfolders. Impossible to find tasks unless you know where they are. What does deleting the SMC Preferences.xml file do? I realize that is in the enterprise version but can't imagine deleting a file if we don't know what it does. The first question in this thread by EJ Stanley is still unanswered and I have the same problem. Only used the product for about 8 years now. Always been the same issue. Would appreciate a response and please ask for help internally if the question above isn't clear. Thanks. Dean.

Posted Wed, 03 Oct 2018 00:27:08 GMT by

It works fine for me.
I have a task named "Call Job Test" in my personal sub-folder under the main "Tasks" folder.

I go to Tasks and type Call Job Test and hit enter.

It takes a few seconds, but then all the results come in as shown in their GIF image.
If you search using double quotes, it searches for that exact text too which helps.

You must be signed in to post in this forum.