Posted Thu, 17 Oct 2019 22:13:05 GMT by

I have been trying to get a SFTP step to connect but I get the following error:

 

Error Code:33338

Error Text: FTP failed (Error: Connection lost due to error 10058)

 

From the Automate logs I only get: Error 7

 

I have been able to connect to the site using WinSCP.  I have used auto settings and Custom.  I have tried to match up the ciphers with what WinSCP is using and I still get the same error. 

From WinSCP:

Doing Diffie-Hellman key exchange with hash SHA-256

Initialised AES-256 SDCTR client->server encryption

Initialised HMAC-SHA-256 client->server MAC algorithm

Any help would be appreciated.

Automate version 11.1.30.3

Windows 2012 R2

 

Regards,

Alan

Posted Sat, 19 Oct 2019 03:18:20 GMT by

Hi Alan,

 

It would appear that you have an open case for this issue.  To assist you, we would like to have a copy of the WinSCP debug log, as well as the Automate FTP task to review the settings.  If this is possible, please update via the case.

Posted Wed, 08 Apr 2020 01:25:41 GMT by

I have the same issue, has this been resolved and what was the solution.

Posted Wed, 08 Apr 2020 23:09:29 GMT by

Hi Ray,

Are you able to connect, on the same machine, to that FTP server using a 3rd party FTP program such as Filezilla or WinSCP. If so, please change send the debug connection log as well as the Automate FTP task to review the settings to Support.Automate@HelpSystems.com.

Posted Wed, 15 Apr 2020 00:07:51 GMT by

Hi - I'm having the same issue.  My connection uses a password only authentication scheme - no SSH key at all.  My password is obviously typed into the SFTP task.  My username and server name are coming from automate constants.  I'm able to use WinSCP from the agent server where I have this configured to run without any problem.  I have inspected the WinSCP connection properties and its pretty straight forward, SFTP version 6 with fallback enabled. I changed the SFTP logon action in the automate task to support sftp2,sftp3,sftp4,sftp5,sftp6.  The only thing I'm suspect of is the upload buffer size which from the automate help looks like it needs to be set to 131702.  Here is my AML for the FTP Logon action:

<AMFTP ACTIVITY="logon" SERVER="%varFTPServer%" USERNAME="%varFTPUserID%" PASSWORD="AM5H5qK3BZQ6LGmvQiaGiFqczprDvp5NH9hVdD4jft9D9Q=aME" TYPE="sftp" PORT="22" LOGFILE="D:\Apps\Log\GHRISO_Upload_%varDate%.log" OVERWRITELOG="no" TIMEOUT="15" UPLOADBUFFERSIZE="131702" SFTPVERSIONS="Sftp2,Sftp3,Sftp4,Sftp5,Sftp6" SFTPHOSTKEY="validate" PROXYTYPE="none" SESSION="FtpSession1" />

 

Every single time I try to run the task it errors out on step 11 which is the SFTP logon step with the error:

FTP failed (Error: Connection lost due to error 10058)

Here is my ftp log file:

------------------------------------------------------------------------
Date : 4/14/2020 11:52:32 AM
------------------------------------------------------------------------
4/14/2020 11:52:31 AM : Connecting to bnym-sdwnftp2.eagleaccess.com connection type is Sftp.
4/14/2020 11:52:32 AM : Server key [78128df537da50823378e76c0924cd9a] received.
4/14/2020 11:52:32 AM : Authentication type [Keyboard] used
4/14/2020 11:52:32 AM : Password-based keyboard interactive login.
4/14/2020 11:52:32 AM : Authentication type [Password] used
4/14/2020 11:52:32 AM : Error 114

 

Any ideas? 
Thanks,

--Kevin

Posted Thu, 16 Apr 2020 22:48:27 GMT by

Hello Kevin,

The error is an authentication error, so there is something missing from being able to access the site. Are there any percent signs in the password?

Was this working at one point, or is it a new task?

Are you successfully connecting from the same machine that AutoMate is installed on?

Posted Tue, 12 Apr 2022 12:00:39 GMT by Javier Trapero TNT
Hello.<br> It happens exactly the same.<br> With Winscp I connect perfectly and with Automate it gives me the same errors as Alan.<br> How did you solve it?<br> <br> This is the error message<br> <br> 12/04/2022 13:45:06,localhost,ConsCorrDyDPutFiles: FTP failed (Error : Connection lost due to error 10058)<br> <br> And this is the Log.<br> ------------------------------------------------------------------------<br> Date : 12/04/2022 13:47:11<br> ------------------------------------------------------------------------<br> 12/04/2022 13:47:11 : Connecting to secureftp.deyde.es connection type is Sftp.<br> 12/04/2022 13:47:11 : Error 7<br> <br> Thank you.<br> &nbsp;
Posted Thu, 09 Jun 2022 15:17:00 GMT by Grant Christensen Wipro Infocrossing Systems Engineer
Was a solution to this ever found/posted?&nbsp; I have same issue.<br> Can Connect with 3rd party to site with sFTP/SSH, using password and SSH Key.<br> AutoMate fails with 96258, extra logging shows error 114<br> ------------------------------------------------------------------------<br> 6/9/2022 9:57:53 AM : Connecting to 168.166.193.236 connection type is Sftp_Public_Key.<br> 6/9/2022 9:57:53 AM : Server key [eaca0687c854baca46170119b4096ad4] received.<br> 6/9/2022 9:57:54 AM : Authentication type [Publickey] failed<br> 6/9/2022 9:57:54 AM : Authentication type [Password] used<br> 6/9/2022 9:57:54 AM : Error 114<br> <br> I have my task configured to use the same SSH key as the 3rd party software.
Posted Fri, 30 Sep 2022 21:39:33 GMT by Steve Martinez Yokohama Tire Corporation Manager, IT Technical Solutions
I too am receiving this same error. Any updates or resolution on this yet?
Posted Wed, 12 Oct 2022 11:53:35 GMT by Tim Girvin RSDC IT Network Supervisor
<p>We started receiving the same error yesterday morning. We can connect using WS-FTP Pro client from the same system that Automate in installed. We have Automate installed on a second system with a copy of the task, it fails to connect as well.</p> <p>I've confirmed with our partner that no changes or restrictions have been made to the server we're trying to connect to.</p> <p>Any updates or resolution for this issue?</p> <grammarly-desktop-integration data-grammarly-shadow-root="true"></grammarly-desktop-integration>

You must be signed in to post in this forum.