Posted Tue, 18 Jan 2022 15:31:41 GMT by Daniel Sidler Horizon21 AG
Due to a change on one of our partners side, I need to reconfigure the SFTP connection on a file transfer task. When testing with the new connection info, I get FTP failed errors as follows:

In FTP Browser: "Error: Connection lost due to error 96258"
In log file: Error 105

Partner site operator gave the following info:

------ QUOTE  -----

•    hmac-sha256    
•    hmac-sha512
•    [email protected]
•    hmac-sha2-512
•    hmac-sha2-256    
•    [email protected]
•    [email protected]
•    hmac-sha2-512-96
•    hmac-sha2-256-96    
•    hmac-ripemd160

•    aes128-cbc    
•    aes128-ctr
•    aes192-cbc    
•    aes192-ctr
•    aes256-cbc    
•    aes256-ctr
•    blowfish-cbc    

•    diffie-hellman-group-exchange-sha256    
•    ecdh-sha2-nistp256
•    diffie-hellman-group14-sha256    
•    ecdh-sha2-nistp384
•    diffie-hellman-group16-sha512    
•    ecdh-sha2-nistp521
•    diffie-hellman-group18-sha512    

•    x509v3-rsa2048-sha256    
•    ecdsa-sha2-nistp384
•    x509v3-ecdsa-sha2-nistp256    
•    ecdsa-sha2-nistp521
•    x509v3-ecdsa-sha2-nistp384    
•    [email protected]
•    x509v3-ecdsa-sha2-nistp521    
•    [email protected]
•    x509v3-ssh-rsa    
---  END QUOTE ---

When testing with WinSCP on the same machine, the connection works and I can see the following connection details:

---- QUOTE ----
File transfer protocol = SFTP-4
Cryptographic protocol = SSH-2
SSH implementation = SSHD
Encryption algorithm = AES-256 SDCTR (AES-NI accelerated)
Compression = No
Server host key fingerprints
SHA-256 = ssh-rsa 2048 uddH1t8Q-REDACTED-5DKGsQnLWGZu6R1Y=
MD5 = ssh-rsa 2048 b3:6f:13:55:-REDACTED-9:52:2c:52:e2:1b
Can change permissions = Yes
Can change owner/group = Yes
Can execute arbitrary command = No
Can create symbolic/hard link = Yes/No
Can lookup user groups = No
Can duplicate remote files = No
Can check available space = No
Can calculate file checksum = No
Native text (ASCII) mode transfers = Yes
Additional information
The server supports these SFTP extensions:
---- END QUOTE ----

I tried these settings in Automate, without success. Besides that,  I believe by keeping everything on AUTO it should just work.

There's one thing however. The password I was given contains special characters, namely a bracket "(", and a hashtag "#*. Could these cause any issue?

Using Automate

Posted Fri, 21 Jan 2022 09:10:29 GMT by Daniel Sidler Horizon21 AG
Replying to my own post here in case anyone comes across a similar case. It turned out that I had to manually try several combinations of protocols and ciphers until I found a working one. Apparently leaving things to AUTO does not always work. Information found in the logs was also not too helpful unfortunately. 
Posted Wed, 09 Feb 2022 00:21:00 GMT by Jennifer Young Erlanger Health Systems
I am getting the same error.  What were your final settings?
Posted Thu, 17 Feb 2022 18:08:41 GMT by Fred Shindle Idaho Power Co
Daniel or Jennifer,
I would also be interested in what combination either of you found to work.
I have also run into the same issue and I am trouble shooting.  I have came across other SFTP issue doing the same as you have, trying each and every combination in HOPES one works.  
I can say the SFTP or FTPS 'functionality' (and error logging) of Automate is extremely frustrating, I have expressed that to support.

I also find multiple post with folks having issues and rarely see a resolution.

Posted Wed, 23 Feb 2022 15:51:00 GMT by James Ray USCB America
I am experiencing the same thing with random connections. I would be interested in the combo that works here as well.&nbsp; <grammarly-desktop-integration data-grammarly-shadow-root="true"></grammarly-desktop-integration>
Posted Wed, 23 Feb 2022 17:18:13 GMT by James Ray USCB America
Just an update for anyone who would like to try, I set the MAC Algorithm to&nbsp;HMAC_SHA2_256<br> <br> Left everything else at All <grammarly-desktop-integration data-grammarly-shadow-root="true"></grammarly-desktop-integration>
Posted Fri, 25 Feb 2022 15:32:18 GMT by IT Dept Nationwide Credit Corp
I wanted to let all know that the change to the MAC Algorithm to HMAC_SHA2_256 worked for me.
Posted Wed, 02 Nov 2022 21:00:23 GMT by Public Employee Credit Union
This SFTP command appears to work during a trial version of Automate Premium Our current Version is Automate Professional Can you send me the installer for Automate Profressional 11.7 and the validation key associated with our account for this new version?
Posted Mon, 12 Dec 2022 00:27:56 GMT by Bob Mclaren
If it helps anybody, we encountered this issue when upgrading from 11.4 to 11.7 and we were able to resolve it by changing the cipher selection from "Auto-adjust" to "Legacy".
Posted Mon, 30 Oct 2023 16:05:34 GMT by David Croney ABRH Personal/Home Email
This has happened to me twice. The fix both times was: Cipher(s) Selection - Custom and MAC Algorithm(s) - HMAC_SHA-256. 
The explanation from support was: “We have come to find that many SFTP servers are updating their security internally. When this specific issue arises, it means that the server doesn't allow specific/all algorithms to be "auto detected". The correct algorithm must be manually entered/chosen for higher security.”

You must be signed in to post in this forum.